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Chapter 1. Sonargraph's Next Generation -
SonargraphBuild
SonargraphBuild integrates quality checks into the continuous integration build and can create XML and HTML reports via an
Ant task or shell scripts. These reports contain all information about quality issues and calculated metrics. The XML report can be
used for further downstream processing via transformations. The XML schema for the report can be found in <sonargraphBuild-
inst>/doc.

SonargraphBuild additionally offers the possibility to mark the build as failed based on issues detected during the analysis. So, if
you have written custom queries via Groovy scripts that check on the proper usage of an external library or detect a code smell,
you can be sure that it is detected immediately.
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Chapter 2.  Licensing
When you start Sonargraph you will be asked for an activation code or a license file. For additional licensing and pricing
information please contact <sales@hello2morrow.com>

2.1. Getting an Activation Code or a License
When you have purchased a Sonargraph license, an activation code or a license file will be delivered to you.

There might be a program for free Sonargraph licenses which are time-limited and/or size-limited. Please register on our website
and check the available programs.

In order to replace a valid license by a new one, choose "Help" → "Manage License..." from the user menu in the GUI-based
product. Sonargraph licenses are bound to a named user. The usage by a different user is a violation of the license agreement.

2.2. Activation Code Based Licensing
Activation code based licensing activates Sonargraph licenses via Internet. Every activation code is customer specific and
represents a pool of Sonargraph user licenses as purchased and licensed to the specific customer. Activation code based licensing
technically requires that Sonargraph has internet access.

Activation code based licenses support a feature that allows customer-driven transfer of a Sonargraph user license to another
user after some amount of time. This works like this:

• When an activation code based license is requested, Sonargraph automatically requests a license ticket from the hello2morrow
license server. This ticket expires after some time, for example after 30 days. During these 30 days, the use of the Sonargraph
installation that requested the ticket is licensed (by the user who ran Sonargraph when the license ticket was requested).
Sonargraph can be used during this period without any access to the Internet.

• After the ticket of a Sonargraph installation has expired (in our example scenario, this happens on the 31st day after the ticket
has been requested), one of two things typically happen:

1. The same Sonargraph installation is started again. Sonargraph then notices that the license ticket has expired and lets the
user know about it by presenting a dialog to manually request a new ticket from the hello2morrow license server, for the
same activation code or a different one if desired. The new ticket again is valid for the same time period. You can toggle

the feature at ' Help → Renew License Ticket Automatically ' to have Sonargraph silently perform license ticket requests
using the current activation code, without further user interaction.

2. Alternatively, the user of the installation might not continue to work with Sonargraph ; then the license is now, after the
expiration of the ticket in the Sonargraph installation, available to some other user. The hello2morrow license server will
supply a license ticket to the next user that requests one for the given activation code.

Note that the number of license tickets that can be supplied by the license server for some activation code might be more than
one. For example, a company might license Sonargraph for 20 users. The same activation code can be used by all of them, but
as soon as the 21st license ticket is requested for this activation code, this request will be denied. A new request for a ticket will
only be fulfilled after one of the already supplied tickets has expired, so that at any one moment, at most 20 non-expired license
tickets exist for the activation code.

It is not required that the same user requests a replacement of an expired license ticket; any user that knows the activation code
can request one of the free tickets. This mechanism reduces the effort needed for license management in a changing user group.
However, in order to avoid any misuse we strongly encourage you to restrict the information about your activation code to those
persons who are supposed to use Sonargraph .

If you have any suspicion about misuse please inform <support@hello2morrow.com> immediately. We can promptly
deactivate an activation code so that any further misuse is stopped and provide a new activation code to you.
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2.3. Proxy Settings
Activation code based licensing technically requires that Sonargraph has Internet access. If your network configuration does not
allow direct Internet access, but provides access through an HTTP proxy instead, you can specify the host name and port of the
proxy server. If the proxy server access is password protected, you can supply a user name and a password in order to authenticate.

For the GUI-based product, the activation code and proxy access data is supplied by selecting "Help" → "Manage License" →
"Configure Proxy Settings" or "Preferences…" → "Proxy Settings" .
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Chapter 3.  Getting Started
This chapter summarizes what is needed for SonargraphBuild to run.

3.1. Installation Requirements
The following prerequisites must be fulfilled for SonargraphBuild :

1. Microsoft™ Windows™ , Mac OS-X or Linux® operating system.

2. Java Runtime Environment 1.8 or higher

3. At least 2048 MB RAM (Win32: 1400 MB)

3.2. Prerequisites
1. If you plan to run SonargraphBuild via ANT or the command line you need to download it from our web site:  https://

www.hello2morrow.com/products/downloads  and extract the Zip file to a convenient location. If you are using Maven for
your build process you only need to install SonargraphBuild if your build server has no Internet connectivity.

2. If the machine that executes SonargraphBuild has internet access, use an activation code parameter to obtain a ticket from
your pool of licenses. If the machine does not have internet access, you need to obtain a license file and pass the location of
this file as a parameter to your build.

3. A "software system" must have been created via Sonargraph.

https://www.hello2morrow.com/products/downloads
https://www.hello2morrow.com/products/downloads
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Chapter 4. Configuration
This chapter summarizes all configuration parameters for invocation of SonargraphBuild. Examples for batch scripts and an
example Ant build file can be found in the "example" folder within the installation. The batch scripts start SonargraphBuild as a
Java application and specify an XML file for the detailed configuration. The configuration for both environments is the same.

The configuration for Maven contains additional parameters that control the automatic download and update of SonargraphBuild.

NOTE

The attribute "logLevel" affects the logging after the SonargraphBuild engine has been started. Setting it to "debug" and
below will generate additional debug information into the report.

WARNING

Setting the attribute reportType to "standard" only generates metric values for "system" and "module" levels. "full"
generates values for all element levels, but results in a significant larger report!

4.1. Report Creation
Attribute Mandatory Description Default

activationCode No Sonargraph license activation code. If this
parameter is not specified, you must specify a
license file parameter (see below).

No default

licenseFile No Sonargraph license file location. If this parameter is
not specified, you must specify the activation code
parameter (see above).

No default

languages No The languages that should be initialized, separated
by ",". The fewer languages are specified the faster
the startup of SonargraphBuild. If no value is
specified, all languages will be initialized.

Ant/Maven: Java; Cmd-
line: All languages

installationDirectory Yes Installation directory of SonargraphBuild No default

systemDirectory Yes Directory of the Sonargraph System
(xyz.sonargraph)

No default

virtualModel No The virtual model to be used when checking for
issues.

Modifiable.vm
(SonargraphArchitect
license), Parser
(SonargraphExplorer
license)

workspaceProfile No The profile file name (e.g. "BuildProfile.xml") for
transforming the workspace paths to match the
build environment.

No default

reportDirectory No Target directory for the created report Current directory

reportFileName No The target file name (without extension) <system-
name>_<timestamp>

reportType No "standard" only creates metric information of
system and module level. "full" creates metric
information of all levels.

standard

reportFormat No "xml", "html" or "xml, html" html

snapshotDirectory No Target directory for the created snapshot. Only
if either this property or snapshotFileName is
provided, a snapshot will be generated.

Current directory
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Attribute Mandatory Description Default

snapshotFileName No The target file name (without extension). Only
if either this property or snapshotDirectory is
provided, a snapshot will be generated.

<system-
name>_<timestamp>

proxyHost No Proxy host No default

proxyPort No Proxy port No default

proxyUsername No Proxy user name No default

proxyPassword No Proxy password No default

logFile No Path of the log file to be used for SonargraphBuild. ${currentDir}/
sonargraph_build.log

logLevel No Level of logging detail. One of: off, error, warn,
info, debug, trace, all

info

Table 4.1. Configuration for Element "sonargraphBuild"

Example
This is an example configuration for creating an XML and HTML report:

<sonargraphBuild 
    activationCode="_your activation code_"
    languages="Java" 
    installationDirectory="../.."
    systemDirectory="../javaProject/AlarmClock.sonargraph" 
    reportDirectory="./_temp/report"
    reportFileName=""
    reportType="full"
    reportFormat="xml,html"
    snapshotFileName="./_temp/AlarmClock.snapshot" 
    proxyHost="" 
    proxyPort="" 
    proxyUsername=""
    proxyPassword="" 
    logLevel="warn">
</sonargraphBuild>

4.2. Specify Conditions for Build Failure
SonargraphBuild can check for the existence of specific issues and mark the build as failed. The nested "failSet" element of the
"sonargraphBuild" element can include any number of "include" and "exclude" definitions based on the issues that are either
built-in (like duplicate warnings, cycle group warnings, etc.) or custom issues created via Groovy scripts.

TIP

The issue type that must be specified for include/exclude definitions can be determined via the Properties View of
Sonargraph .

TIP

If you want the build to fail only for newly introduced issues, apply resolutions like "Ignore" or "Fix" to the already
know issues in Sonargraph and only filter for resolution value "none".

TIP

If you want the build to fail because of certain metric values (e.g. Lines of Code per Source File), define a threshold for
that metric in Sonargraph to create issues if files grow too large.
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The include/exclude definitions are applied in the following sequence, regardless of their definition order:

1. First all include definitions are matched against the set of existing issues.

2. Then the exclude definitions are applied and the set of previously matched issues is reduced accordingly.

Element Parameter Mandatory Description Default

failSet failOnEmptyWorkspace No Marks the build as failed if no
components are found. Possible values
are "true" or "false".

true

include/exclude issueType Yes Name of the issue type or "any" for
wildcard matching.

No default

include/exclude severity No Severity of the issue. Possible values
are: error, warning, info, none, any

any

include/exclude resolution No The issue's resolution type. Possible
values are: task, ignore, any, none

none

Table 4.2. Configuration Parameters for Build Failure

Example

This is an example failSet definition:

<sonargraphBuild
...            
  <failSet failOnEmptyWorkspace="false">
    <include issueType="any" severity="error" resolution="none"/> 
    <exclude issueType="ScriptCompilationError"/>
    <include issueType="Supertype uses subtype"/>
    <include issueType="any" severity="warning"/>
    <exclude issueType="ThresholdViolation"/>
  </failSet>
</sonargraphBuild>

The console output provides some basic information about the number of issues matched by either "include" and "exclude":

Failed:
Sonargraph: Start creating report...
Sonargraph: Opening system...
Sonargraph: Refreshing system...
Sonargraph: Creating report...
Sonargraph: Check if build should be marked as failed...
Include filter [issueType=any, severity=error, resolution=none] matches 0 issue(s).
Include filter [issueType=Supertype uses subtype, severity=any, resolution=none] matches 0 issue(s).
Include filter [issueType=any, severity=warning, resolution=none] matches 2 issue(s).
Exclude filter [issueType=ScriptCompilationError, severity=any, resolution=none] removes 0 previously matched issue(s).
Exclude filter [issueType=ThresholdViolation, severity=any, resolution=none] removes 0 previously matched issue(s).
Summary: Build failed as 2 issue(s) match the specified failset on virtual model 'Modifiable.vm'.
Sonargraph: Finished.
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Chapter 5. Executing from the Command-
line
SonargraphBuild can be executed as a standalone Java application which enables the integration in any kind of continuous
integration environment. The necessary configuration is straight-forward and example shell scripts are provided in the directory
<inst-dir>/example/bin.

All parameters are described in detail in Chapter 4, Configuration

NOTE

SonargraphBuild returns a negative exit code if there are any configuration errors or the analysis detected issues defined
by the failset.
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Chapter 6. Integrating with Ant
The provided SonargraphReportTask makes it easy to integrate SonargraphBuild into Apache Ant based builds and generate
HTML or XML reports containing info about metrics and issues of a software system. Additionally, using the optional "failSet"
element, the Ant build can be marked as failed if certain issues exist.

Prerequisites:

1. You need at least Ant 1.8.3 installed.

2. Set the environment variable ANT_HOME.

3. Include ANT_HOME/bin in your PATH environment variable.

The following shows the SonargraphReportTask definition:

<taskdef name="sonargraphBuild" 
     classname="com.hello2morrow.sonargraph.build.client.ant.SonargraphReportTask">
  <classpath>
    <fileset dir="${sonargraph.build.installation}/plugins">
      <include name="org.eclipse.osgi_3.10*.jar" />
      <include name="com.hello2morrow.sonargraph.build.client*.jar"/>
    </fileset>
    <fileset dir="${sonargraph.build.installation}/client" includes="*.jar" />
  </classpath>
</taskdef>

An example Ant build.xml is provided in the directory <inst-dir>/example/ant. All parameters are described in detail in Chapter 4,
Configuration
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Chapter 7. Integration with Maven
SonargraphBuild comes with a Maven plugin that makes it easy to run it from Maven builds. The plugin is able to automatically
download and install SonargraphBuild if your build server has Internet connectivity. You can make the build fail depending on
issues detected by SonargraphBuild.

Prerequisites:

1. You need at least Maven 3.0.5 installed.

2. The plugin requires at least a Java 8 runtime.

TIP

Add the following repository to your Maven settings.xml, so you do not need to repeat it in your project's pom.xml:

<pluginRepository>
    <id>hello2morrow.maven.repository</id>
    <url>http://maven.hello2morrow.com/repository</url>
</pluginRepository>

7.1. Example POM
The following example shows how to integrate the Sonargraph Maven plugin into your project specific pom file. For multi-
module projects it is sufficient to only add the plugin to the pom of the root project. It runs as an aggregator after all modules
have been compiled. The example project in the installation contains a complete pom.xml. Typically you would run the plugin
with a command-line like the following to ensure that everything is compiled from scratch before the report is created. The first
command-line explicitly specifies a version, the second one uses the Maven prefix resolution (check  Maven Prefix Resolution
for details):

mvn clean compile com.hello2morrow:sonargraph-maven-plugin:8.7.0:create-report

mvn clean compile sonargraph:create-report

The following shows the relevant section of a pom.xml file that demonstrates the configuration of the Sonargraph functionality:

  <pluginRepositories>
    <pluginRepository>
        <id>hello2morrow.maven.repository</id>
        <url>http://maven.hello2morrow.com/repository</url>
    </pluginRepository>
  </pluginRepositories>
  <build>
    <plugins>
        <plugin>
            <groupId>com.hello2morrow</groupId>
            <artifactId>maven-sonargraph-plugin</artifactId>
            <version>8.7.0</version>
            <configuration>
                <systemDirectory>${basedir}/crm-domain-example.sonargraph</systemDirectory>
                <activationCode>...</activationCode>
                <autoUpdate>true</autoUpdate>
                <failSet>
                    <failOnEmptyWorkspace>true</failOnEmptyWorkspace>
                    <includes>
                        <include>
                            <issueType>NamespaceCycleGroup</issueType>

https://maven.apache.org/guides/introduction/introduction-to-plugin-prefix-mapping.html
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                        </include>
                        <include>
                            <issueType>ArchitectureViolation</issueType>
                        </include>
                    </includes>
                    <excludes>
                        <exclude>
                            <issueType>ScriptCompilationError</issueType>
                            <resolution>none</resolution>
                        </exclude>
                    </excludes>
                </failSet>
            </configuration>
            <executions>
                <execution>
                    <goals>
                        <goal>create-report</goal>
                    </goals>
                </execution>
            </executions>
        </plugin>
    </plugins>
</build>

In this example the build will fail if the project contains a package cycle or an architecture violation without a resolution.
Since the parameter 'installationDirectory' is not defined, the Maven plugin will automatically download the newest release of
SonargraphBuild and also will keep it updated automatically. Of course this requires that the build server has access to the Internet.

7.2. Special Maven Parameters
The Maven plugin uses the same parameters as the Ant task. The following table lists only additional parameters and those where
the default values differ from the parameters defined in Section 4.1, “Report Creation”.

Attribute Mandatory Description Default

installationDirectory No Installation directory of SonargraphBuild. If
unspecified the plugin will automatically download
the latest release of SonargraphBuild.

No default

autoUpdate No If the plugin is configured to download
SonargraphBuild automatically, this property
decides if it also should be updated automatically if
a new version becomes available.

false

reportDirectory No Target directory for the created report ${basedir}/${target}/
sonargraph

prepareForSonarQube No Creates an XML report and stores it at ${basedir}/
${target}/sonargraph/sonargraph-sonarqube-
report.xml, where the SonarQube Maven plugin
expects it.

false

useHttpProxyHost No The id of a proxy entry in the Maven settings. If
defined the plugin will use this proxy for all http
communication.

No default

logFile No Path of the log file to be used for SonargraphBuild. ${basedir}/${target}/
sonargraph/
sonargraph_build.log

Table 7.1. Special Configuration Parameters for the Sonargraph Maven Plugin
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NOTE

All attributes starting with "proxy" are ignored by the Maven plugin. Use the attribute useHttpProxyHost instead.

NOTE

The definition of a failSet is the same as described in Section 4.2, “Specify Conditions for Build Failure”, but uses
nested elements instead of attributes (see example pom.xml above).
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Chapter 8.  Integration with SonarQube
For Java projects the findings of Sonargraph can be stored and visualized in  SonarQube  using the SonarQube Sonargraph
Next Generation Plugin. The plugin is currently only available for download on our website  https://www.hello2morrow.com/
products/downloads  and is compatible with SonarQube versions 5.2 and higher. The plugin will soon be moved to the official
SonarQube repository.

NOTE

The plugin reads the information of the XML report that has been generated using SonargraphBuild. You need to
configure your build pipeline accordingly.

NOTE

The plugin is currently only available for Java systems.

8.1. SonarQube Configuration
The first step is to activate Sonargraph rules in the quality profile of the project. If no Sonargraph rules are activated, the plugin
will skip this project. You can either search using the term "Sonargraph Integration", or the tag "sonargraph-integration".

The next step is to configure a dashboard to include the Sonargraph widgets.

Figure 8.1. SonarQube Dashboard Configuration

Core metrics and rules of Sonargraph are pre-defined in the plugin. If you want to track custom metrics that are generated via

scripts, you first need to export the report meta-data via the standalone application's menu "File" → "Export Meta-Data...". The

http://http://www.sonarqube.org/
https://www.hello2morrow.com/products/downloads
https://www.hello2morrow.com/products/downloads
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directory of this meta-data file needs to be specified in the plugin's configuration page. The additional metrics will be available
after a restart of the SonarQube server and an additional execution of the SonarQube checks.

NOTE

This configuration is affecting all projects that use the Sonargraph plugin. If you have several projects with different
metrics, store the separate meta-data files in the same directory. The plugin will merge the info of the different
configuration files.

Related topics:

• See the section about "Workspace Profiles" in the user manual of the standalone application, if the root directories on your
build server do not match the workspace definition.

• Chapter 7, Integration with Maven

8.2. SonarQube Ant Runner Configuration
If you use the SonarQube Ant Runner the Sonargraph XML report must have been created and this report must be configured
for the Sonargraph SonarQube plugin using the following parameter:

<property name="sonar.sonargraph_integration.report.path" value="${path.target.report}" />

The example project contains this configuration in the Ant build file.

8.3. SonarQube Maven Configuration
If you use the SonarQube Maven plugin, you must set the following parameter in the configuration of the SonargraphBuild
Maven plugin:

<configuration>
    <prepareForSonarQube>true</prepareForSonarQube>
    ...            
</configuration>

The SonargraphBuild Maven plugin will automatically create an XML report (if not already configured) and will copy the report
to ${target}/sonargraph/sonargraph-sonarqube-report.xml for the root project and all modules (excluding those with packaging
"pom").

The example project contains an example pom.xml and also a batch file that demonstrates how the check can be called from
the command-line.
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Chapter 9.  Integration with Jenkins
With Jenkins Sonargraph Next Generation Plugin for  Jenkins  jobs the findings of Sonargraph can be used to let builds fail, or
mark them unstable. Additionally Sonargraph metric values are stored for every build and can be visualized as charts.

9.1. Jenkins Server Configuration
The first step is to configure one or more versions of Sonargraph Build in "Manage Jenkins" → "Configure System". Click
"Sonargraph Build installations..."

Figure 9.1. Jenkins - Sonargraph Build Configuration

and select a name, a version and an installer.

Figure 9.2. Jenkins - New Sonargraph Build

9.2. Jenkins Job Configuration
Add post build action "Sonargraph NG Report Generation & Analysis" to your job.

Figure 9.3. Job - Post Build Action

First decide if Sonargraph Build is used to create the report,

https://jenkins-ci.org/
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Figure 9.4. Report - Generate With Sonargraph Build

or there already exists a report generated by an upstream build action.

Figure 9.5. Report - Pre Generated

When Sonargraph Build is used to create the report fill out all required information:

Figure 9.6. Report - Standard Options

By pressing "Advanced..." some more options pop up:

Figure 9.7. Report - Advanced Options

9.3. Charts Configuration
To see some charts, a meta-data file must be configured, and either all contained charts/metrics are shown, or a list of charts/
metrics to be shown can be given. If you want to track custom metrics that are generated via scripts, you first need to export the

report meta-data via the standalone application's menu "File" → "Export Meta-Data...".
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Figure 9.8. Job - Chart Configuration

Figure 9.9. Job - Select Charts

9.4. Build Configuration
Finally the reasons for marking the build as failed or unstable can be set:

Figure 9.10. Mark build failed or instable

Related topics:

• See the section about "Workspace Profiles" in the user manual of the standalone application, if the root directories on your
build server do not match the workspace definition.

• Chapter 7, Integration with Maven
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Chapter 10. Trademark Attributions,
Library License Texts, and Source Code
Eclipse is a trademark of Eclipse Foundation, Inc.

IntelliJ is a trademark of JetBrains s.r.o.

Java and all Java-based trademarks are trademarks of Oracle Corporation in the United States and other countries.

Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.

Microsoft, and Windows are trademarks of Microsoft Corporation in the United States and other countries.

Other company, product, and service names may be trademarks or service marks of others.
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Chapter 11. Legal Notice
All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that
the following conditions are met:

• Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer
in the documentation and/or other materials provided with the distribution.

• Neither the name of hello2morrow GmbH nor the names of its contributors may be used to endorse or promote products derived
from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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Appendix A.  SonargraphBuild API
Documentation
 SonargraphBuild API is documented via JavaDoc that is available within the installation of the product.

Link to JavaDoc of SonargraphBuild API.

./javadoc/index.html
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